CodinGame sponsored challenge discussion


#106

Thanks, but I already assumed this, but it’s not helping me to figure out the connection :confused:


#107

I loved it!
I tried to do it yesterday and it was so frustrating.
But today I had it clear in my mind and finally beat it.

Thanks to whoever made this puzzle.


#108

This puzzle it’s awesome.
Hope it’s not a to big of a spoiler but : CENSURED :-))))


#109

If I submit it seems not all tests succeed, but in simulation they do. I don’t find the reason. :confused:


#110

I got 1606 points.
// admin edit don’t spoil the puzzle
How do people get such high scores ?
Also is the offer still valid ? No point for me to do all this if it’s for nothing. :slight_smile:


#111

Wow, after another attempt i went straight to 2618 points. To think that my main issue was that i was trying to predict too much, and a more “simple” solution worked wonders.

Now I really need to know if the offer is still valid. :grin:


#112

Hi,

Back in the days, we could see the seeds for IDE test-cases. We cannot anymore, even though this information is part of the reverse-engineering process.

Could you please provide us with the IDE seeds ? It is a crucial piece of information imo.

Thanks


#113

No, sorry :slight_smile:
Allowing players to test custom configurations on games with a viewer generated too many errors on our side. That’s why we removed it.


#114

Hi,

I’m not asking to re-enable the option to test custom seeds. I’m asking to just have the seeds, as text. That’s already enough to pursue the process locally.


#115

In C, the default code is wrong! Probably the input has been change, but the default code that reads the stdin wasn’t.


#117

When is this due? The “Reverse Engineering” challenge?


#118

Thank you so much! Looking at that nonsense debug output, I had almost assumed the puzzle was too cryptic for me, I didn’t even think that the newline treatment of input in the default code could be wrong.


#120

I am getting a strange timeout error while waiting for the input. I modified my input function (I am using python3) to print to stderr at the same time that I receive inputs. The timeout always occurs while waiting for the last pair of integers in the loop.

I’m assuming that there’s nothing I could have done in the previous turn that would have broken the stream of inputs in the next turn, but maybe that’s a bad assumption?

Edit:
Meant to add that this timeout does not occur on the first turn. It always occurs on the same turn for the same scenario (e.g. turn 82 for M1L1). There doesn’t seem to be any pattern to when it occurs in regards to the rest of the inputs.

Edit2:
I fixed an error in my BFS and now I no longer get the error. I can’t for the life of me how the BFS error affected the timing of receiving inputs, but I’m just glad it’s gone.


#121

Doing B C D E over and over again is fun
got around 1000 points