Botters of the Galaxy - Bugs

Use this topic to report bugs or remarks about the Botters of the Galaxy challenge.


The referee code is publicly available on Github


Special thanks to the creators (AntiSquid , Illedan & Wildum) and the testers (csj & nmahoude)


Please, in French, replace every “héro” by “héros”.


I tried to use the Referee to create all my code structure, with objects and basic method for simulation.

But I reached the maximum size of code, and I’m not able to submit anymore.
However, I did not copy paste the whole referee code, I removed all functions that I don’t need.

This is very restrictive, it means that we cannot recode the whole simulator? Is it possible to have this limitation increased or I should simplify the simulator?


Looks like a platform bug, not an issue with particular game, but earlier I didn’t have such issues with simple lambdas.

My code is timeouted on:

List<Unit> myHeroes = -> == WORLD.myTeam && u.unitType == UnitType.HERO).collect(Collectors.toList());

(I just filter all heroes from a very small list of 12 units).

Once it is replaced with

    List<Unit> myHeroes = new ArrayList<>();
    for (Unit unit : state.units) {
        if ( == WORLD.myTeam && unit.unitType == UnitType.HERO) {

it works fine (except it takes 5X more code).
Earlier there were some issues with larger lambdas, but for this game first (warmup) step is very different from second one, so most of the code is not touched in warmup and failed to compile in 50ms. Is it possible to fix it somehow?


Hello - There is something I don’t understand in the victory conditions of Wood 2.

Look at the screenshot:

I have more kills (8 vs 7).
I have more last hits/denies (3 vs 0), if the green number counts that.

But yet, for some reason the game stops and I loose here at turn 109 - while I still have remaining life …
I checked and I didn’t see any errors in the output.

Can someone help / clarify these victory conditions for me. Thanks!

@redmitch: Hover your mouse over the red spot in the bottom-right corner, might help you. If not, click the REPLAY & SHARE button and give us the link.


So it seems that we aren’t given the scores for this game, like the older frustrating contests.
And it is difficult to calculate from the inputs, so the Legend leaguers will need to try but the rest of us just hope we are winning?
Can they be added to Silver league, before “it’s unfair to add them because some people have already put effort in”? (we had to rewrite our code from Wood to Bronze anyway…)

Assuming you meant sources instead of scores, the rules say:

For more details you can check the Referee on GitHub

Maybe you missed that in the lot of rules.

That red dot on the timeline indicate an error(far right below the game itself). What does it contain?

Ok Thans - I can only hover the red-dot in full screen for some reason. It says “Timeout Redmitch”, but I have no message in the error console. Weird.

Here is a link to a replay:

That means you did not output 1 command that round. Maybe you miss an ELSE after all IFs?
Atleast, the game is missing output from your code at this round.

Ok found the bug! The missing ‘\n’ …
Thanks for you help.

umm why did I lose this match? the log doesnt say anything about illegal moves.

Hi ! I’m unable to launch the referee, what I’m doing wrong ?
When I launch the main class and go to localhost:8888 I get an angularJS error :

Tried to launch it from Netbeans and mvn command line, same results. I’m not really familar with maven and angular …

Could somebody explain to me moving of LaneUnits?
For example first move of unit_id 5. It is starting from (160,490) and going to tower (1820,540), right?
So its v is (149.9320030065, 4.5160241869), and after t=1 I expect its position to be (309.9320030065, 494.5160241869) and rounded (310, 495), right?
But I see new position (310, 490).


Replay player bug report(maybe it’s general and not related to this contest only).
Looks like the standart output is not always in sync with the displayed image.
If I step between the frames sometimes the hero is on position 398 other times it’s 200 at frame 4(image vs std out).
Position.x of the hero is printed as DEBUG(bug at e.g. frame 4)

I slightly modify the default code to verify this.

The minions target a position Y which is horizontal to their starting position and an X according to the enemy tower.
They move like this until an enemy is within 300 range of the unit. They would for the remaining of this round move towards this unit and stop to attack if they get in range.


I’m facing a weird issue where the game says I’m trying to issue a BASH skill with the VALKYRIE.

Hero1: HULK

Look at 18/45.

Seems the game is switching the positions of the two heros for that turn???

Thanks Illedan :slight_smile: