Can't set known languages in profile

Seems like I can’t get the “I’m skilled in” part of my profile to show up, no matter what I try.
I’ve tried:

  • Simply checking relevant languages
  • Checking only one language
  • Checking languages only in upper part (before the “view more” button)
  • Checking languages only in bottom part

It actually saves the choices since when I come back to settings I see them checked. I know about caching and tried various ways to invalidate it, including viewing my profile from separate browser - still no success.

I have the same problem.

It’s OK now. Thanks.