Clojure submissions consistently passing all tests but getting 0% on submission


#1

I am beginning to suspect something is wrong with how clojure is evaluated during submission compared to how it is evaluated for pre-submission tests. Here are a couple examples where my code passes all pre-submit tests but scores 0% during submission:

ANEO challenge code:

(ns Solution (:gen-class))

(defn -main [& args]
  (println
    (let [max-speed (read)
          light-fns (for [_ (range (read))]
                      (let [dist (read) duration (read)]
                        (fn [speed] (zero? (mod (int (/ (* (/ dist 1000 speed) 3600) duration)) 2)))))]
      (some (fn [speed] (when (every? #(% speed) light-fns) speed))
            (range max-speed 0 -1)))))

Clash of Code "Shortest" challenge:

Print the sum of digits of a decimal number converted to binary.
Example: 15 in decimal => 1111 in binary, output will be 4.

(ns Solution (:gen-class))

(defn -main [& args]
  (println (count (filter #{\1} (Integer/toBinaryString (read))))))

#2

I've just tried resubmitting some older solutions of mine(that previously worked correctly) and have the same problem so it does appear something is broken when submitting.


#3

We're looking into it, thanks for the report


#4

We didn't manage to find why it only fail on submit, we will have to wait until the team is back from holidays :confused:


#5

Any update on this?


#6

Not yet, the team is just back but didn't start to tackle the problem.

Edit: Nvm, they already fixed it, it will be deployed tomorrow.


#7

Should be fixed, sorry for the delay :kissing_heart:


#8

Indeed, submiting works now. BUT running test cases before submission is now broken ("internal error"). This affects the puzzles, previously affected by the submission bug as described above (e.g. WAR)!


#9

FIXED ! :blush:


#10

Nice, thanks :smile: