[Scala, Multiplayer] Problem with Scala on Multiplayer Games (PONG)

I recently started to program in Scala and I thought Ultimate Tic Tac Toe would be a good way to learn. The problem is that I often get the following cryptic bug/issue/feature:

Standard Output Stream:
Game Summary:
MathJason eliminated: Invalid output.

Nowhere did I specify PONG as an output. Also any debugging code I wrote doesn’t get displayed. It happens 100% of the time when my bot plays against itself. Right now my game logic is trivial, but I have a lot of classes, so it must be the compilation is taking too long.

  • What does PONG mean?
  • If it is the compilation is taking too long, since I am new to Scala, how can I speed up my compilation time?

Actually, this PONG stuff happens even with the default Scala code. If I play the default code against itself in the CodinGame IDE, then the above bug always happens. (Tried two browsers as well.)

Upon further debugging, this seems to be a bug in most, if not all, of the Multiplayer games. I reproduced it on every one I tried, including Ultimate TicTacToe, Botters of the Galaxy, and Great Escape (to try an old game).

  1. In the IDE, set the language to Scala.
  2. Use the default code (or any other Scala code).
  3. Set all players to be the IDE code.
  4. Run

Then the result is always:

Standard Output Stream:

This is clearly a bug.

1 Like

Same here, encountered today while was adapting my BotG contest code to multiplayer game. But never had it earlier.

I catch this also with league boss but not with other bots.

I had a “bug” when used various online C++ compilers, could see program output of other users when it was supposed to be a segfault. Maybe something similar here, just a guess.

Same here, on Ultimate Tic Tac Toe, Scala, against my submitted bot.

And both in the IDE as between submitted bots:

Since @_CG_SaiksyApo and @TwoSteps have liked my original post, I assume they are looking into this (or at least filed an internal bug report).


I hope when it is fixed, they let us know.

We did indeed file an internal bug report. As far as I have understood, it happens when you play 2 Scala codes together.


Hi everyone,

If it can help, I encounter the same problem, not only against another Scala code.

Here are the examples :

@TwoSteps, thanks for looking into this, however it is not just Scala vs Scala. While it always happens with Scala vs Scala, it sometimes happens with Scala vs Other.

For example, I just tried to submit the simplest bot in the UTTT bronze league. The bot just takes the last valid move (from the provided inputs) and plays that. It is only 5 lines of code different from the default Scala code stub. It should not reasonably time out. Here are the times when I get PONG in competition. None of them were Scala. (Because I didn’t played against any Scala bots in Bronze).

Totals: 11 PONGs in 220 games
Opponents: 1 Python3, 1 JavaScript, 9 Java


JavaScript bots (PONG)

Python3 bots (PONG)

Java bots (PONG)

Thank you @Eeeval and @MathJason. I’ll push for the resolution of this bug.

If it can help, i got the bug here: https://www.codingame.com/replay/298735402

I’m in C++, no Scala.

But tyrcho (who produced the PONG output) uses Scala.

We found the cause of the bug. We’re currently fixing it.

I’m curious about the cause of the bug. Can you share it ?

Yes please! We sincerely promise not to post it on Daily WTF. :see_no_evil:

It’s complicated. :stuck_out_tongue:

1 Like

This is fixed!

1 Like

I like complicated bug stories !

1 Like

Is it related to the pong game? :smiley: