Test in IDE not working

Test in IDE wasn’t working before I’ve submitted a new version for this contribution:

For some reason version 9 can’t be found for a preview even tho it was listed as the active version on the contribution. After I’ve edited and submitted a new version it registered version 10 as active and it works now.

But if you try to start a preview with version 9 it still returns the same error.
I used following code to test that:
fetch(‘services/Contribution/startPreview’, {method: ‘POST’, body: `[${‘512255ee4b586a5cf9ff812987123aeddad5’},${9}]`})
and it returns {“id”:404,“message”:“Couldn\u0027t find the question related to this contribution”}


Thanks for reporting. However, if the latest version works, it’s ok. If the issue reoccurs, we’ll look into it.

1 Like

Another one:

This time I didn’t edit it so you can properly test it.
this one too:

I did edit this one so it’s working now but you can use
fetch(`services/Contribution/startPreview`, {method: `POST`, body: `[${`4276079e5339f70653af8c014ef64e1f7bc3`},${7}]`})
To check that previous version is missing.

played a bit with this contribution:

It was disabled 4 times from fastest by the bot and exactly 4 versions are missing (10,12,14,16).

So looks like every time the bot removes a mode from a contribution it creates new version that doesn’t work for “test in IDE”.

Oh I see now. This bug is actually already in our backlog. And you’re right, it happens when the moderation bot removes a mode. Thanks

1 Like