Vox Codei animation problem

Hey everyone,

Since recently the animation on Vox Codei (hard) isn’t working for me anymore. It doesn’t prevent me from testing my code but without a graphical output it’s kinda hard to see what’s going on.
I tried other puzzles and had no problem with them.

Picture of how it looks like : http://tinyurl.com/hm6bh84
I’m using Firefox 44.0.2

Edit : I just looked at Vox Codei (very hard) and the same problem occurs

Can you open the console (F12) and refresh the page? Any error message could be useful to us. I can’t reproduce…

Here it is (partly in French, I don’t think you mind :slightly_smiling:)

Log on pushmessage server as 1256312 25f5d293.codingame.js:38:3818

Error: a.config is undefined

VoxCodei1 drawer init: 430,242 25f5d293.codingame.js line 41 > Function:1057:1

“Pixi.js v1.6.1 - http://www.pixijs.com/” 25f5d293.codingame.js:50:19340

VoxCodei1 drawer init: 860,484 25f5d293.codingame.js line 41 > Function:1057:1

Blocage d’une requête multi-origines (Cross-Origin Request) : la politique « Same Origin » ne permet pas de consulter la ressource distante située sur https://files.codingame.com/codingame/vox-codei/challenge/bombsLeft.json. Raison : l’en-tête CORS « Access-Control-Allow-Origin » est manquant.

L’utilisation d’XMLHttpRequest de façon synchrone sur le fil d’exécution principal est obsolète à cause de son impact négatif sur la navigation de l’utilisateur final. Consulter http://xhr.spec.whatwg.org/ pour plus d’informations. qui-e40bc86a2be00d0f1598.js:4:51939

Error: Permission denied to access property “documentElement” resizer.xml:19:1

Log on pushmessage server as 1256312 25f5d293.codingame.js:38:3818

That’s the error I suspected… “missing Access-Control-Allow-Origin”. We have troubles figuring out the cause of that problem, we use Amazon S3 and the configuration seems valid.

You can try with a different browser, maybe it will work. Usually that issue disappear by itself.

I thought some of my ff addons were interfering with that failed request so I tried with Edge, but the problem occurs too :confused: And it was working fine just 2 or 3 days ago.

Also I don’t have any problem with the other puzzles, looks like it’s specific to this one.

Ok not sure what to make of it but maybe that will help you : I used a vpn to change my ip, and the problem disappeared. Now if I disconnect and go back to my normal ip, it’s broken again.

I’m not surprised and that’s why it’s difficult for us to investigate… When asking for a file, amazon may not use the same server to serve the file and that server doesn’t send the header that is missing.

Looks like you’re not the only one having that problem : http://stackoverflow.com/questions/17533888/s3-access-control-allow-origin-header

At least a vpn can be used as a temporary workaround, good luck in your work :slightly_smiling: