Wondev Woman - Bugs

Hi fellow coders,

Use this topic to report bugs or remarks about the Wondev Woman challenge.

If you still don’t know what’s Wondev Woman yet, take a look here : https://www.codingame.com/contests//wondev-woman

The referee code is publicly available on Github
Codingame Java: https://github.com/CodinGame/WondevWoman

- Fixed: A variable name type was a reserved keyword in some stubs.

When I launch my code it works the first time but if I do it again nothing moves.
Others bot games work fine, I’m on Chrome.

1 Like

I had the same problem in the past, and had it again for this contest. Each time I could solved it by changing the option “Use hardware acceleration when available” in the Chrome settings. For some contests it works with acceleration, for others without.

It worked, thanks :slight_smile:

1 Like

I often get error:
Standard Error Stream:
Error: Could not find or load main class Player

In the Player: PlaceToHighTooltip at Turn 16, looks like it needs a better Text.
Can you please add stack high to x and y in the debug mode tootip?

1 Like

I cant see the units move when I play my code.
I tried disabling hardware acceleration (as suggested above )but that didnt work either.
I am on Chrome and am using CG Sync to upload the file

Lose from the first step because of movement is impossible :sweat_smile:.


invalid input. Expected 'MOVE&BUILD ’ but found ‘Wating for you.’

legalActions == 0 though

But you can see it’s impossible to move, its means legalActions == 0 at 1st step and every command is invalid.

Can I always rely on legalActions?

What to do if there is none?
There is no WAIT action.

also, ACCEPT-DEFEAT Well done! is a valid action but not mentioned in the rules.


Hi, thanks for the referee’s code.
Do we have access to the MultiReferee or is it not publicly disclosable?

1 Like

I’m not sure if this should be considered a bug, but I’ve recently come across this configuration:

The match is almost over before the game starts. Maybe the initialization of the board should be more careful.

lang: C#
i’ve got error text with no other info (about line, class…):
error CS1644: Feature `declaration expression’ cannot be used because it is not part of the C# 6.0 language specification

how I can fix it? what feature I should delete?

  1. line shows in code editor. sorry for my screaming in forum before look carefully :blush:
  2. feature was
    var cur = Board.Read( Size, out string mv );
    using string as out parameter without declaration first. VS compiles it.

That’s C# 7 :slight_smile:



Probably not a bug, but a bit strange place in referee:

Why we have this filter operation and why we are using .equals(…) if it is not overloaded?

same thing happens to be in Chrome; with or without hardware acceleration

That line is asking: “is there a unit in the square I want to build in, and that unit is different to my unit that is moving?”
So it is ok to move away from a square and build where you were just standing.
It is not ok to move then build under a different unit.