Back to the Code game field display problem

Hi,

Right now in the Back to the Code competition there is a problem with the display of the game field when testing the code. The first time a code is run after the page is freshly loaded, it works fine. However, if I rerun the test, the game field no longer displays. It will only reappear after a complete reload of the page. I use firefox but several other people reported the same problem in Chrome and Chromium.

The problem started today, before it was fine. Please do something about it! Thanks.

2 Likes

Update: VulcanAugustus discovered that enabling webgl in the browser settings fixes this problem. Still it needs fixing or at least documenting that the website requires webgl on.

I don’t know if this is the same bug, but sometimes there are display problems in replay as well.

In the browser (Chromium) console, I see this error message:

Uncaught TypeError: Cannot set property ‘alpha’ of undefined (VM4258:263)

For instance, it always happens on this replay.

WebGl is enabled.

Here is a screenshot.

It seems to be fine in Firefox, even though there are some errors in the browser console.

I’ve experienced the same issue yesterday but I was unable to reproduce. We will do our best to fix the problem but it won’t be easy if we can’t reproduce… The bug is not necessarily caused by our code, it could also be a bug with Pixi.js or your browser.

This should be fixed by now.

Unfortunately, it still doesn’t work for me :

  • chromium : Version 37.0.2062.120 Ubuntu 12.04 (281580) (64-bit)
  • chrome : Version 45.0.2454.101 (64-bit)

Do you know a browser that will make it run correctly for sure please?

PS : it works with firefox, but the synchronisation with an external editor is not available :s

Have you refreshed the page (and made sure it is not in cache)? Maybe you’re still running the old version of the viewer.

I still experiment the same issue even after I cleaned my cache data
(the button “Effacer les données de navigation…” on chromium and chrome)

Is there any trick ? Am I the only one ?

Can you please send a screenshot with the console open ?
Are you sure it’s the same error ?

As far as I can see, the bug I reported in this thread is fixed.
Perhaps, fabien_rozar had another bug.

Yesterday, after a moment, I decide to develop in the online editor in firefox.
And great news, this morning everything works again under chromium.

So, thank you :slight_smile:

I am sorry for the delay of my answer…

I have this problem too. Some puzzles take a long time before finally not loading in Chrome on a Macbook. WebGL enabled, latest version installed, cached cleared, etc. Switched to Firefox and it started right up.