[Community Puzzle] Find the missing plus signs in addition

Coding Games and Programming Challenges to Code Better

Send your feedback or ask for help here!

Validated by @cedricdd,@papyjo and @pluieciel.
If you have any issues, feel free to ping them.

I’m slightly confused. I have failed last TestCase named “59 digits in O” but event though after submiting my code I got 100%.
Remove the test case or add validator to make it consistent, so no one will waste time for optimizing if that’s not required.


Same thing happened to me, but I don’t think it’s a problem. It’s better if the validator has a slightly lower treshold than the testcase than the opposite. Imagine if you finally pass the last testcase and submit and it timeouts, it would be even more irritating.
There are many possible optimizations for this problem, if you add them one by one, at some point it’s good enough and that’s it.
The fact that we both landed right between testcase treshold and validator treshold is a bit unfortunate but the puzzle creator cannot anticipate everything in every language.
And if we want to pass both testcase and validator we can try to optimize a bit more.


I am in the same boat as you. However, I noticed that pluieciel’s code passes all test cases and all validators. I’m working through that code right now to try to figure out what I missed.

Well, now I am just mad that I did not fight hard enough to pass the last test case. I have been through @pluieciel code and the algorithm is brilliant. I agree with @BigZettt that the validator should be made a bit tougher so that the less than adequate algorithm I put together cannot get 100% when submitted.

What about zeros? Is this test valid?


The way the zeros should be handle is not defined in this puzzle, there are no zeros in any of the tests/validators.

The “mini” function is from the author. I spent too much time trying to pass the “59 digits in O” with Clojure (still not successful). My Clojure solution finally passed the validator at the limit-line…(i.e. need to submit several times and pray for luck :))) )
On my laptop, the last Test takes “Elapsed time: 38385.4 msecs”, but last Validator only takes “Elapsed time: 5396.7 msecs” (about 8 times faster). I guess that’s why some solutions can pass validator but not last test…
Still trying to optimize my Clojure solution.

Hello @cedricdd, @pluieciel I am having a problem here.
I can pass the tests, but I fail two of the vaidator tests. I suspected that this was due to the sorting required, and fixed that (I think) but I still fail two of the validators (“Another with more than one solution” and “Ten terms again”)
Any help is welcome as I have absolutely no idea of the reason for which they fail.