[Community Puzzle] May the Triforce be with you!

Coding Games and Programming Challenges to Code Better

Send your feedback or ask for help here!

is there some error here or why does it say it found nothing when my output matches the ‘.’ that it wants?

1 Like

I had something a bit similar at the start of the puzzle.
However I can’t remember exactly what it was.

I know it was gone when I started to manually print out the triforce to make sure it was working or not.
Sorry I can’t help much more than that, I think it’s a case of dull feedback mixed with a printing issue.

Yeah, when I manually print the string that it wants it goes away, it’s probably something with printing the array instead of as a string

maybe u printed

  • *\n
    or smth like that
1 Like

I had this “Nothing” error. That was just a “\n” at the wrong place

hi, all validators for groovy failed. I tested N=2 in the IDE and it worked. Other languages worked also for the same algo. what should i check next? thanks.

There are some possible reasons for why all validators fail. I assume that you have not hardcoded the testcases…

  1. You are timing out.
    Try printing the time taken as well to see if you area on the edge of the time limit.
  2. Lots of people are submitting now due to the unofficial contest. So there may be some server issue, but the CG team handles them very efficiently. So if you submit after an hour or two, the issue is likely resolved and if the failures continue it is probably in your code.

hi, thanks for your time.

  1. groovy code is faster than java code that passes the validators, and a bit slower than scala code.
    replacing + by .concat, then by just printing one by one without concat did not help.
    replacing fancy (1..N).forEach and 1.upto(N) by simple for c-like loop helped a bit (down to 6-7ms).
  2. i can wait for the end of the contest. but i ran scala and java again w/o issue. scala and groovy codes have same algo.

i guess i should spend time on contests over than on easy training. :slight_smile:

the problem here is with the platform, not with your code. (it’s not related either to the community contest imo)

I’ve tested your code in the contribution and it passed the validators in the IDE. I’ve created a bug ticket for the devs


this has been solved. Sorry for the long wait

1 Like