[Community Puzzle] Maze

Hey, I have solved 01-05 Test Cases and 01-04 IDE Cases but am failing IDE 05 - not sure why it may be failing?
I believe the correct exits are being identified and in their correct numerical order but yeah unsure why it’s failing.

When you fail IDE tests, you can easily check why:

1 Like

My apologies I mean " Validators" not “IDE”

Solved it with 100%
I was removing tested tiles from my array which in some scenarios affected valid exits - all working now!

Same for me: all IDE tests are passing but Test n°4 from validator is failing but I don’t understand why.
Do you guys encounter same issue?

It was a sorting error. Cool thing that I learn is that scenario test same thing between IDE and validators. That’s how I figured out it was a sorting error.

Continuing the discussion from [Community Puzzle] Maze:

All IDE tests are passing but Test n°2 & 5 from validator are failing but I don’t understand why.
Any idea? I can send my code to somebody!

If you want, you may send me your code in private message and I’ll take a look.

Edit: There is only one issue: the exit coordinates are not sorted before output.