Death First Search - Episode 1 - Puzzle discussion

Feel free to send your feedback or ask some help here!


This challenge doesn’t work for me. Nothing seems to happen after the first autogenerated cin (I’m trying it in c++, I put a cerr before an after and only the one before is displayed. Also there is no message to say that I win or lose). Same thing with java. I couldn’t try it with another browser (than firefox) yet, so maybe it’s a browser issue ? Has someone done that one since the update ?

1 Like

Hello Lilian,

it works fine for me (also since update). I used JavaScript, and my browser is also Firefox (version 31).

Hello Fred, you used picture of Skynet Finale 2 instead of 1, isn’t it ?


Ok, so I switched to my laptop with updated browsers and it works. For the record, the version that didn’t work was Firefox 22

Après validation du code, lors de l’analyse et du test de la triple étoile, après 21 tours le virus est stoppé au centre sans être passé par un noeud de sortie, malgré tout cela affiche échec.
Alors que lors des tests cela affichait la validation après les 37 tours
Est un bug ou doit on complètement bloqué le virus avant ces 21 tours ?.

I passed all the tests but those test are not testing for an situation when endpoint-virus-enpoint, so that there are 2 endpoints available. Now you can block random until the virus is 1 point from a endpoint.


L’échec, ça marque que ton programme n’a pas pu répondre, ou que le virus a trouvé un chemin ? Si c’est qu’il a pas pu répondre, ton programme est peut-être trop lent, ou a un cas ou rien n’est affiché.

!'ve got a weird thing going on. I’ve written a code (in C), and tested it on the test cases, and everything was ok. Then i submitted it, and it failed on the Star and Triple Star cases. When i replay it after validation, it shows, that there is only 1 round, and the agent is not moving. As if it were an infinite loop or segmentation error. But it worked on the same tests before submission.
I tried to validate the default C program, and it is 0% of course, but only the Several Path case works. The other 3 ends in 1 round, without the agent moving. I tried the default C++, C#, Javascript as well, all the same.
Have any of you ever faced this problem?


Kinda looks like a bug I had, though it didn’t work even in training tests. Using more up-to-date browser was the solution for me

I’m using Firefox, and it says i have the newest version. I’ve just downloaded Chrome, and the bug is still there. I’ve even tried it with IE, nothing has changed.


comment on accède à la console de test ? :blush: ;

cordialement vincent;

Exactly the bug i have. Im running it through all the test cases and everything is okay, 100% completion. After submitting my code it says “star” and “triple star” tests have failed — agent is not moving. Code was written in C++. Pls help!

même chose que tout le monde pour le test de la triple étoile , l’agent ne bouge plus passé un certain nombre de coup :slight_smile:

1 Like

Du coup je confirme qu’il y a bien un bug. J’avais obtenu 100% mais je viens d’essayer de resoumettre mon code et le test de la triple étoile plante quand il reste 9 bonnes arrêtes à couper

J’ai voulu tester aussi, mais pour moi la triple étoile passe, aussi bien en test qu’en validation, sous Javascript.

@vincent6363: Yes sorry, you can no longer access the test console on the new CodinGame site. I have removed the description from the topic

@lilian_cartellier, @sylvain_denis564 : je ne reproduis pas le bug. Vous pouvez envoyer votre code à si vous voulez qu’on jette un coup d’oeil.

@fearrrous: I do not reproduce the defect. Please send your code at, we’ll take a look!

I had the same problem (passing all tests but failing those two upon submission).

Previously I was just outputting “0 1” if I hadn’t found a node to cut; I changed my code to find a node that wasn’t severed and it now passes all tests.

So the issue might be outputting a link which is already severed.

1 Like