Feature update: chat rework

Such Wow, Much tutorial.


I did read it later on a computer.

I was just mentioning that the chat window interferes with the reading on mobile. I gave up on mobile and read it only after reaching a computer where I can read it.

1 Like

Here are some hints for Mac users.
Pidgin download (for Mac) suggests Adium client (it’s OK).
On first run it proposes to add an account

Make sure to choose the XMPP for Service. Grab your ID from from the FAQ page (must be logged in to CG). Use your CG password.

From the menu File, choose Join Group Chat…

In the following dialog, fill in the details about the chatroom (general or general_fr) and the conference server:

That’s it. See you there!

Update 2016-05-20 18:00 (UTC+2)

Today we fixed some minor and less minor issues on the chat, including:

  • Messages displayed two or three times
  • Client scrolling to the bottom unexpectedly
  • Some major performance issues
  • Automatic reconnection
  • Rised maximum number of connections on the server

Thank you for all the patience, feedbacks and guides on external clients, this is all really appreciated :slight_smile:

1 Like

(Feedback) I don’t remember whether this was the case before, but it’s weirding me out right now in the last message displayed in the reduced variant of the web chat box:

  • it’s prefixed by its author and a colon. This results in lines like “Author: hello!” In most multi-user chatrooms, the “person: message” convention is used to address people, the opposite of what is happening here.

  • doubly confusing when the last who talked is ourselves.


  • obviously remove colon, perhaps IRC-style angle bracket(s), or a dash, or parentheses, or…
  • for messages from self: remove altogether or replace pseudonym by a localized “(me)”.
1 Like

I followed JBM’s tutorial to connect to the chat with Pidgin, it worked yesterday before that update and doesn’t anymore today. Same computer OS, config. All I get is “connection reset by peer” or “server closed the connection”.

Edit: the chat box on the website cant connect to chat anymore as well. So it’s very…white now.

Same for me :frowning:

When I type something like join Some_Room (when I have multiple rooms open), on some occasions, The current window switches to some other room instead of switching to Some_Room.

A similar issue can be seen when closing chat rooms. When I close a room, sometimes, the current room switches to some other room instead of switching to the recently visited room.

And now, the chat doesn’t seem to load for me. And I can see a bunch of other errors in the console. Here is the full console output:

fbd5279e.codingame.js:37 Log on pushmessage server as 1120414

https://push.codingame.com/socket.io/?EIO=3&transport=polling&t=1463833390764-3&sid=0fb9024a-3138-4814-b7d2-5c7127693a8a Failed to load resource: net::ERR_EMPTY_RESPONSE

https://push.codingame.com/socket.io/?EIO=3&transport=polling&t=1463833390664-2&sid=0fb9024a-3138-4814-b7d2-5c7127693a8a Failed to load resource: the server responded with a status of 500 (Internal Server Error)

23:1 XMLHttpRequest cannot load https://push.codingame.com/socket.io/?EIO=3&transport=polling&t=1463833390664-2&sid=0fb9024a-3138-4814-b7d2-5c7127693a8a. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://www.codingame.com' is therefore not allowed access. The response had HTTP status code 500.

https://push.codingame.com/socket.io/?EIO=3&transport=polling&t=1463833391419-4&sid=0fb9024a-3138-4814-b7d2-5c7127693a8a Failed to load resource: the server responded with a status of 500 (Internal Server Error)

23:1 XMLHttpRequest cannot load https://push.codingame.com/socket.io/?EIO=3&transport=polling&t=1463833391419-4&sid=0fb9024a-3138-4814-b7d2-5c7127693a8a. No 'Access-Control-Allow-Origin' header is present on the requested resource. Origin 'https://www.codingame.com' is therefore not allowed access. The response had HTTP status code 500.

fbd5279e.codingame.js:37 Log on pushmessage server as 1120414

Failed to parse SourceMap: https://www.codingame.com/assets/defer/html-sanitizer-bundle-d16d6db88ba7f52519e32490435898443349921e4f227e7bf443b7f66dfc8096.js.map

fbd5279e.codingame.js:64 WebSocket connection to 'wss://chat.codingame.com:5281/xmpp-websocket' failed: Error in connection establishment: net::ERR_TIMED_OUT

That last error (Time-out) seems to be appearing in a regular interval.

And please add a horizontal scoll bar to the list of users so that it is possible to see the full usernames of users who have long usernames.

Is chat working right now? I can’t connect to chat for the last few hours.

i can’t too

let’s create a chat topic here on the forum that’ll be as a chat until they fix the chat ?)

The irc channels are still here :slight_smile:



#codingame / #codingame_

I can’t view any messages or the list of people who are online. It was working perfectly fine two days ago.

looks like they deactivated chat to rescue the server yesterday - it was overloading the server, and the server almost crashed

Edit: server configuration changed to handle more than 1024 connected users.

Yes, it and still not working…

Can you describe the problem?

Not sure if honest question or bad faith pretend-it-never-happened. (not pasting a GIF, I’m overusing that meme way too much already)

All the XMPP clients I use are nefariously bad at providing useful debug information, but at the time AndreyAleksejev wrote, my experience was still in some limbo state between connection refused and timeout. Specifically, enough to reach STARTTLS, nothing of interest past that.

The client I’ve still got the logs for managed to connect half an hour later, at 18:33 CET. But yeah, right now it is working.

  • We’ve fixed the main connection issue before Andrey message, if there are still people who can access to the chat, we’d like to know.
  • We’ve also fixed the connection with external clients around 18:30 CET (still a temporary patch, we’ll need to reboot the server at some point).

I’m just trying to know if there is a problem that we haven’t fixed yet.

More details: the exact reason is that we’ve changed a module to handle more than 1024 connections but that new module apparently contains a known bug that broke the authentication of the external clients… So the limbo state was the auth one :). Our current workaround is temporary.