Fighting the editor

Hey there,
I’m loving CG but one thing that can drive me nuts is the editor, especially 2 points :

  • We can’t copy more than a few lines of code. I assume that’s an anti-cheat mesure but it’s really annoying that it’s activated all the time for everyone. I’m working on a contribution puzzle right now, spent some time on writing the solution, then wanted to make a backup of the code locally. I can’t, or at least not without copying the code snippet by snippet which is ridiculous.

  • The paste bug, or at least I assume that’s what it is. Everytime I paste text with indentation, the number of indentations increases for the next lines, making the code look more and more like a stair case. Here an image is worth more than a description, I simply copied then pasted the for loop.

Paste bug

Those points aren’t deal breaking but sometimes it feels like I’m fighting the UI.

I regularly copy my code from CG to my pc and vice versa, and I never seen any limitation. I can copy hundreds of lines in one CTRL-A + CTRL-C. And I never experienced indentation problems neither…
Concerning the first point: don’t you have a script or extension that can interfere with the IDE ?
And about the indentation, perhaps the problem come from your local text editor that don’t use the same characters to indent the code ?

My only real extension on firefox is ublock origin, and I deactivate it for the CG site.
I just tested on Edge and you’re right, both points are working correctly (knowing that just changed my life to be honest :slight_smile:)).
That makes me wonder if something’s up with firefox then, I haven’t tweaked it or done anything out of the ordinary.

I use Firefox too so that’s strange… Perhaps a configuration problem. Have you some privacy and security parameters active in your Firefox settings ? “Don’t track me” or other ?

Is Firefox up to date?

Do you have any other issues system-wide on your PC? 500 firefox tabs maybe?

I have some options like do no track me enabled, but I tried deactivating it and everything related to cookies/trackers/etc and it doesn’t change anything.
FF is up to date and I don’t have 500 tabs open :slight_smile: usually i have 3 to 5. No other issues on my pc. Note that I generally know my way around computers, I write software for a living.

I confirm this issue. It looks the same for me, thus:

  1. I am getting “…” if the copied code is longer then 10 lines
  2. Each line is indented by additional tab

Also, I have to change editor from vim to normal as regular yank and paste doesn’t work between windows.

Indenting problem occurs only when there is an indentation in code (kind of stacking indentations). When undoing changes (ctrl-z) it goes back word by word as opposite to undoing full paste at once.
I would be happy to see it fixed.

FF 68.11 on linux

Well somehow I’m relieved to see I’m not the only one experiencing those issues.

Here is an example of both problems at once, I copied my entire code for a puzzle then pasted it on itself. Note the “…” on line 11, that corresponds to a lot of lines that were cut during the copy process (not the paste process, which means I still get those 3 dots instead of the code if I paste it elsewhere like notepad++).

1 Like

I could paste the same picture.
Please notice, that this problem happens when using “Classic” <- Edit mode <- Settings
With “Vim” yank and paste works as it supposed to, but there is another issue, that the code doesn’t go into clipboard and cannot be copied between windows or programs.

If Vim y/p is fixed, I don’t mind the issue with Classic mode :wink: @Djoums

1 Like

To add some more infos, I spent some time away from home and used the exact same firefox on another computer (using FF sync for addons, settings, etc…) and everything worked fine. So I have no idea what’s going on, it’s hard to imagine that something else than the browser is at play here.

@Djoums: I gave up fighting with the CG Editor.
CG Local is decent and works for me.

FYI I made a reset to my Firefox about:config file and it fixed the issue.
I have no idea which option was the culprit but it may be an old one that carried over time, because I’ve been using FF for years now.