IDE not saving

This has been happening to me more often lately.
I found this:

Saying your code is saved every time you run it in the IDE, which has been my experience previously.
I’m using Chrome on Win 10 64, and lately it has been losing my changes. I run the code to save it every time. I just lost my changes for the puzzle of the week. I absolutely ran it and checked the output after modifying, before closing the window.
Any other info I can give?

Thank you!

I know you go back to the starting code if the puzzle has been modified or corrected by someone, could that apply to your case ?

Thanks for the suggestion. That may have happened before, too, but this time it definitely went back to my previous code, not the default.

I seem to remember seeing somewhere that all the versions I run are saved, if I’m not imagining it. Could it be that the code was saved, but it loaded an older version when I went back in??

You can check that by clicking on “Results” in the left menu of the IDE, then go to the history tab.
You should see everything you have submitted before.

1 Like

Thanks again, that is useful info.
But as of now “Results” is GRAY and I cannot click it.
I just made some small changes and ran my code. The “Results” button is still gray.
I’m using Firefox at the moment. I’ll switch to Chrome and check there.

It’s just happened again.
My code was reverted to an earlier version and the “Results” button is grayed out. I cannot click it.
The IDE is deleting my changes.

Are you sure you have ran your code by clicking “Play all testcases”, “Play testcase” or “submit” before exiting the IDE ? It’s the condition to your code to be saved.

Hello.
100% sure.
Perhaps a clue is that I use two computers.
I often use the Chrome plugin to sync to a local file. I sometimes close down after running my last try (several times to be sure it updates). It indeed updates, it runs and changes its output, and the next time I run, I am on a different computer. At that time, sometimes, even if I use the CodinGame IDE directly and not the sync plugin, my last changes are still missing.
Obviously, the Chrome sync plugin is something else, but I can watch the code update in the IDE before running, I see the updated debug messages that I put in, and it still reverts.
I realize now that the HISTORY under “Results” is only available after solving a puzzle. I just solved the one that reverted on me earlier. Maybe I can find where it happened.

So, if I understand well, you’re saying that the code that is ran is not the one visible in the IDE ?

Sorry, let me clarify. It runs the code visible in the IDE, but if I make some changes, then run the code so my changes will be saved, then close the window, many times, when I enter the same puzzle, I do not see the last code that I ran. I add variables and functions, then come back to find a previous version without them. It is still my code, but not the latest.
It happened yesterday working on the puzzle of the week, The Lost Files.

I see now that I can’t see any of my previous versions of code; the history tab only shows code that was submitted. Are previous versions of code that was run but not submitted still kept somewhere? I wonder if my last code is in fact saved, but maybe the versions are sorting out of order?

I honestly never experimented this kind of problem… Perhaps somebody from the staff could take a look @_CG_Thibaud ?

@BanjoMan I’ll try to have a look today or tomorrow

Hello,

I’m sorry, @BanjoMan, I’ve not been able to reproduce the issue you’re having. Do you manage to reproduce the bug using only 1 computer (and possibly not CG sync?)

No one else has reported such a bug so it’s highly probable the issue is on your side.

1 Like