Onboarding - Puzzle discussion


After I solved this puzzle I can see: Achievment 0/1.
I thought I should see 1/1. What is wrong?
Thanks in advance.


We had an issue with servers. Achievements are getting recomputed and you should get it.


Thanks for the reply.
I will come back after few days, and i will continue the exploring this site.


my child is in 9th i want to teach him basic coding help me.


I am totally new comer, never coded anything, not with CS background. How do I start?


Any changes applied to this puzzle? Even my old code that passed 100% is failed today. I have tried it with different language, same result aka failed. I even tried to paste the provided solution into the IDE, and surprisingly it failed too.

I think there’s something changed that made the code failed.


Hello, l’m a chinese student, l really like HTML.
Can you help me? My english is so bad.



Hi and welcome to Codingame! I tried it in Java just a minute ago and had no problems. Maybe it was a temporary glitch, or maybe you inadvertently changed your code. It’s hard to tell more without knowing which language(s) you tried.

The solution provided in the IDE is incomplete, by design. The objective is to fill in the missing parts so that it passes all the test cases.


Your current solution in IDE passes the test. So does the solution given in hint. You haven’t submitted any other solution in another language than Pascal. What am I missing?


advice for a newbie interested in learning code
go or Python?


Python then Go.


clever and nice.


Hey:can you help me
plz idk how i can using




Hi, I just registered and started the initial tutorial. After pressing submit in the tutorial, the page get stuck at “Loading… Computing Score”. I have tried in both Java and C++, and nothing happens. I have tried in Chrome and Microsoft Edge. Here is a link to a picture of the situation.


Same here with PHP. It won’t save the result / let me advance…
Tested on Chrome and Firefox @ macos


It seems to be solved now. Happy coding!


We had an issue yesterday with the submits. It is solved indeed.


Hi, i registered today, and try to submit with no luck, so i think this problem still exists

Language - Javascript


Template code for D (which is now available in the list) is missing during the copy/paste step.