Spring Challenge 2022 - Bugs & questions

Please use this topic to report bugs or ask questions about the Spring Challenge 2022


Referee code on Github

Introduction video by Mathis Hammel on YouTube

Bronze statements

Current Bugs (last update: April 26 4pm)

  • [SOLVED] images in .pdf statements don’t show well
  • [SOLVED] date in league popup is not well formatted
  • [SOLVED] Go, Rust, Haskell default code doesn’t compile
  • [SOLVED] image in Wood 1 league popup doesn’t work
  • [SOLVED] missing heroesPerPlayer in statement
  • [SOLVED] threatFor issue (Wrong threatFor? · Issue #7 · CodinGame/SpringChallenge2022 · GitHub)
  • [SOLVED] contest points awarded
  • Clojure timeout issues
  • [SOLVED] interactions with out-of-bound spiders
  • [SOLVED] asymmetry
  • [SOLVED] wrong input value after control

What would happen if a monster is pushed outside of the map? According to this SpringChallenge2022/Referee.java at main · CodinGame/SpringChallenge2022 · GitHub I would expect it to be removed from the game but a the same time, the following lines in the description give me a doubt:

  • Players are not given the coordinates of monsters outside the map. (why would we mention that instead of just saying that the monster will be removed?)
  • A monster can be pushed outside of the map, unless it is within a base radius, in which case it will will be moved no further than the border.

Does it mean a monster outside the map can still target the base without being seen? Maybe I missed something in the referee code?

It would be nice to have wild mana displayed on the viewer or at the end game screen in case the game is decided by it.


I can’t see the animations, everything I see is the gray screen - is this intentional?

Firefox 99.0.1 (64-bit), adblock turned off

I’m also using Firefox 99.0.1 (64-bit), no problem for me.

Monsters can be outside of the map without being pushed there, but they won’t be in a position to target a base: they spawn slightly off screen.

Wild mana does appear in the endscreen when the game is decided by it. If you think that there’s a bug, could you share a replay of a tie with this problem? (Bronze+ only)

In this replay I don’t get the end game screen at all.


It worked fine for me, do you have an error in your browser’s console that might pertain to the webgl rendering?

I don’t get the end screen on Windows 11 / latest Chrome.

Works fine in latest Firefox though :+1:

I also don’t get it on screen, but it is available in the logs.
Also, it would be super useful to always have the value.

My bad, I had debug mode toggle active and it doesn’t show end game screen if it’s active.



getting quite a lot of those in Clojure:

Standard Error Stream:

Code failed: main entry point was not reached in time
(possible reasons: too many static initializer processing

pretty sure no static processing involved … would you have any hint ?

kind regards

1 Like

How does league promoting work ? It’s been 30 minutes I’m ahead of wood 2 league’s boss and I’m not promoted…

1 Like

I see that you’ve been promoted to Wood 1 already. Anyway, league promotion occurs after you are ahead of that league’s boss AND 100% of the battles have been resolved. You may check the percentage of completion of the battles by clicking LAST BATTLES or LEADERBOARD to the left of the challenge statement.

Ok, so I’m out here trying to program in C because I hate myself (and want to practice with it). I was having an issue where I could output my first 3 instructions in the first round fine, but fail to provide the instruction in the second round.

My first thought was that something in my code was taking longer than 50ms but shorter than 1000ms. To debug I started using perror() statements; I put one at the very start of the game loop (before anything happens) and one at the end (just before it reruns the loop). When I ran it again, I saw both my standard error messages show up the first round and neither the second. I didn’t even see the message I put at the start of the game loop print.

Am I dumb, or is there something wrong.

Edit: I’ve fixed my code, but I’m still curious as to the reason why the error message didn’t print. Are there possible errors that don’t show up in the stream?

Yeah, when running in the arena, even simple clojure solutions frequently fail to even start with “Code failed: main entry point was not reached in time”; that doesn’t seem to happen while running the same code in the sandbox.

We’ve had many issues with Clojure during previous challenges and we have been unable to fix it. I advise you not to use it, sorry :frowning: cc @vlad107 @spicausis

okay understood, thanks for confirming :slight_smile: