Unary - puzzle discussion

Feel free to send your feedback or ask some help here!

3 Likes

I have a problem with character ‘%’. Test 3 tells me that ASCII code for ‘%’ should start with a 0, but Python3 keeps telling me that it starts with 1. Could someone tell me where I’m wrong, please ?

54 Likes

The input message consists of ASCII characters (7-bit)

this means if you have a char ‘%’, which binary value is ‘100101’, you have to read it as ‘0100101’ (7 characters)

69 Likes

That was so obvious, thank you very much, ced_29 !

2 Likes

I wondered why ‘%’ didn’t works until I saw that Ascii char of % begin by 0 :slight_smile:

1 Like

I had the same problem with ‘%’ in Groovy (Java). for non alphanumeric values Integer.toBinaryString() was returning 6 not 7 bits.

3 Likes

and this is easy? D: I don’t know how to convert a char to his binary value xd

10 Likes

http://bit.ly/1vzGhqS

16 Likes

The input message consists of ASCII characters (7-bit)

7!

2 Likes

To properly do this the logic needs to use and logic with 2^bit where bit goes from 6 to 0. You see if the bit is on or off then you start counting from 1 the number of occurrences. If you end while counting occurrences you need to load another character and look at bits again. It can be wrapped up nicely in a tight loop. No string ops needed…

All tests done and after submit i see “Final Score 100%” but in puzzle list i see “0%”. what’s wrong? The same thing with “MIME type” puzzle

Is it still the case after a little time ? I read in some topic that scores are updated every x minutes, not right away

Chuck Norris puzzle result not updated ~1 day and ~1.5 hour MIME types puzzle

1 Like

I’m sure I’m not the only one, but I’ll add myself to the chorus of voices:

I’d have completed this in 1/3rd the time and avoided a lot of fruitless imaginary bug chasing if the problem statement had said that Chuck Norris uses a 7-bit binary representation.

3 Likes

“The input message consists of ASCII characters (7-bit)”

All said

10 Likes

The 3rd and 4th tests shows fails with the message:
Found: “…0”
Expected: "…0 "

Are tests correct? Why the final space?

2 Likes

maybe ‘\n’ ?? have you checked? Or maybe you put too much ‘\n’

[Edit] nothing nothing :slight_smile:

You know that moderator and administrators can see all of your edits, right? :stuck_out_tongue:

4 Likes

I have the same issue. Tried manually correcting to see if that worked and it kept adding 0 and spaces. Did you ever fix yours?