What is Oops... a system error has occurred!

I was edit my contribute and test my code suddenly ‘Oops… a system error has occurred!’ show up when I ran the code , I found some of this in my clash of code game too and some weird suff like I can’t see me test case It won’t load. What is going on???

1 Like

Same for me at the moment - some test cases simply do not run and only give that error. :thinking: At the same moment, when I try to go to ‘show testcases’ and check one of the cases in/out, it gives me a ‘Network error: status 500’. At the moment my internet connection is working fine, so that cannot be the issue.

Same for me. I’ve reported the issue on CG’s Discord server.


Same here, I’ve added a test in my contribution, and then I got the error “Oops… a system error has occurred!” when I tried to test in IDE.

I fixed the root cause of the issue, but now it seems some cache is keeping the errors alive, but I haven’t found where exactly yet (not my area of expertise I’m afraid, so will need help from my colleagues)
I think it only affects questions created/modified today, so hopefully not many questions are impacted
For contributions, updating them should/might be enough to fix the issue
For released questions, I’m afraid it’ll have to wait a little, maybe tomorrow, most likely on Monday
Sorry for the inconvenience


Don’t be sorry, it’s the week-end ! Thank you for your time.

Sometimes I can run only a few tests if I reload the IDE page with CTRL-R.

Same for me

I don’t understand what you mean

Actually, if I click enough on a test button, I can run it.